صفحه 1 از 2 12 آخرینآخرین
نمایش نتایج: از شماره 1 تا 10 , از مجموع 12

موضوع: VRF Lite

  1. #1
    Junior Member
    تاریخ عضویت
    Jan 2013
    نوشته ها
    29
    Thanked: 3

    VRF Lite

    سلام خدمت دوستان و اساتید

    در مورد vrf lite می خواستم بدونم کاربردش بیشتر کجا می باشد و کی ما از آن استفاده می نماییم .اگر امکانش هست در قالب یک شکل توضیح داده بشه
    با تشکر

  2. #2
    Senior Member amir_khalili آواتار ها
    تاریخ عضویت
    Jun 2011
    محل سکونت
    Tehran
    نوشته ها
    196
    Thanked: 355
    سلام
    در MPLS بکار میره که اگه این مبحث و خونده باشی،VRF یادگیریش آسونه/
    اما چکیدش: با نام دیگر Multi-VRF CE ،چندین Instance از جدول روتینگ در یک روتر بوجود میاره و میتونیم هر اینترفیس یا ساب اینترفیسو به هر کدوم از این Instance ها اختصاص بدیم و نتیجش این میشه که بین Customer های یک Service Provider میتونیم همپوشانی (Overlapping) در مورد آدرسهای آی پی اونا در این جدول داشته باشیم.
    MCITP-MCSA-MCTS-CCNA R&S-CCNP R&S-CCIE R&S

  3. The Following 2 Users Say Thank You to amir_khalili For This Useful Post:


  4. #3
    Special Member perspolis آواتار ها
    تاریخ عضویت
    Feb 2012
    نوشته ها
    632
    Thanked: 251
    VRF Lite
    VRF Lite به مهندسین اجازه می*دهد شبکه*های مبتنی بر IP مجزا در دامین*های مختلف یا گروه*هایی بدون نیاز به روترهای مجزا و بدون نیاز به اتصالات فیزیکی مجزا را به هم متصل نمایند. معمولاً برای این منظور دامین*های لایه 3ای مجزا از چندین ابزار ممکن همانند: ACL*ها به منظور فیلتر کردن پکت*ها، Route Filter*ها به منظور فیلتر کردن روت*ها، NAT جهت مقابله با Overlapping فضای آدرس*های IP و لینک*های فیزیکی مجزا بین سایت*ها استفاده می*نمایند. با استفاده از تنها یک جدول Routing Table بر روی یک روتر، مشکلات حاضر به چالش*های بزرگتری تبدیل می*شوند، اما بهترین راه*حل استفاده از یک روتر مجزا جهت برطرف کردن مشکلات خواهد بود.
    پیکربندی مکانیزم VRF Lite بسیار شبیه به دو مرحله 1 و 2 از پیکربندی MPLS/VPN است که پیشتر به توضیح آن پرداختیم. پیکربندی با ایجاد چندین VRF بر روی روتر آغاز شده، سپس اینترفیس*ها به VRF*های مربوطه assign می*شوند تا اینکه روتر VRFی را جهت استفاده در زمانیکه می*خواهد پکت*های را Forward کند، انتخاب نماید. در نهایت هر روتینگ پروتکلی روی VRF مشخصی عمل می*کند.
    برای مثال به سناریوی شکل 48-12 دقت کنید. در این سناریو دو کمپانی (شرکت) با یکدیگر ادغام شده*اند. این شرکت*ها Office*هایی را در هر دو طرف (سایت*ها) دارند، بنابراین کاربران آنها به یک ساختمان در هر شهر مهاجرت کرده*اند. جهت نگه داشتن کاربران بصورت مجزا، کاربران از هر شرکت قبلی در یک VLAN خاص از شرکت قرار می*گیرند. همانطور که مشاهده می*کنید، در این طراحی در VLAN*های سمت راست بر روی شبکه 10.3.3.0/24 یک Overlapping بر روی فضای آدرس IP وجود دارد که می*توانیم با استفاده از قابلیتVRF Lite و پیکربندی آن در این سناریو، مشکل مزبور را برطرف نماییم.

    منبع: کتاب مرجع آموزش CCIE Routing and Switching- مهندس میثم ناظمی- انتشارات ناقوس

  5. The Following 2 Users Say Thank You to perspolis For This Useful Post:


  6. #4
    Special Member perspolis آواتار ها
    تاریخ عضویت
    Feb 2012
    نوشته ها
    632
    Thanked: 251
    [Only registered and activated users can see links. ]
    شکل 48-12

    نکته: نام دیگر قابلیتVRF Lite ، Multi-VRF CE است.
    به عنوان نمونه، پیکربندی VRF Lite بر روی روتر Lite-1 در ادامه آورده شده است:
    ip cef

    ip vrf COI-1
    rd 11:11
    route-target both 11:11

    ip vrf COI-2
    rd 22:22
    route-target both 22:22

    int s0/0/0
    encapsulation frame-relay
    clock rate 1536000
    no shut
    description to Lite-2

    int s0/0/0.101 point-to-point
    frame-relay interface-dlci 101
    ip address 192.168.4.1 255.255.255.252
    no shutdown
    ip vrf forwarding COI-1

    int s0/0/0.102 point-to-point
    frame-relay interface-dlci 102
    ip address 192.168.4.5 255.255.255.252
    no shutdown
    ip vrf forwarding COI-2

    int fa0/0
    no ip address
    no shut
    description to C-1

    int fa0/0.1
    encapsulation dot1q 102
    ip vrf forwarding COI-1
    ip addr 10.1.1.100 255.255.255.0

    int fa0/0.2
    encapsulation dot1q 102
    ip vrf forwarding COI-2
    ip addr 10.2.2.100 255.255.255.0

    router eigrp 65001
    address-family ipv4 vrf COI-1
    autonomous-system 1
    network 10.0.0.0
    no auto-summary
    address-family ipv4 vrf COI-2
    autonomous-system 1
    network 10.0.0.0
    no auto-summary

    به عنوان مثالی دیگر، در سناریوی شکل 49-12، فرض کنید نیازمند ارتباطات OSPF یک بین سایت*های مشتریان هستیم. هر چند به دلایل امنیتی، London نباید در دسترس کاربران Newcastle یا Manchester باشد. همچنین Newcastle و Manchester باید قادر به برقراری ارتباط بین سایت*ها و به اشتراک گذاری روت*ها با استفاده از OSPF باشند. بنابراین می*بایست در این سناریو از قابلیت VRF Lite استفاده نماییم.


    منبع: کتاب مرجع آموزش CCIE Routing and Switching- مهندس میثم ناظمی- انتشارات ناقوس
    ویرایش توسط perspolis : 06-02-2014 در ساعت 07:41 PM

  7. The Following 2 Users Say Thank You to perspolis For This Useful Post:


  8. #5
    Special Member perspolis آواتار ها
    تاریخ عضویت
    Feb 2012
    نوشته ها
    632
    Thanked: 251
    سناریوی Inter-VRF routing با استفاده از VRF-Lite
    به سناریوی شکل 50-12 دقت کنید. در این سناریو قصد ایجاد سه VRF را داریم، در واقع برای هر یک از site*ها، یک VRF را ایجاد می*کنیم. در این سناریو London نقش HQ را برای دو سایت دیگر بازی می*کند. بنابراین، London می*بایست توانایی صحبت کردن از طریق پروتکل OSPF با هر یک از سایت*های دیگر را داشته باشد. هر چند که هر یک از سایت*ها نباید قادر به صحبت کردن با سایت*ها دیگر باشند. بنابراین در واقع ما یک طراحی Hub and Spoke داریم که روتر London نقش Hub و روترهای Branch*های دیگر در نقش دو Spoke آن هستند. همچنین توجه نمایید که در این سناریو، خطوط مستقیم اتصالات فیزیکی و خطوط خمیده نیز اتصالات منطقی (در اینجا فعالیت*های VRF*ها) می*باشند.

    [Only registered and activated users can see links. ]
    شکل 50-12

    در ادامه پیکربندی مربوط به هر یک از روترهای Branchها آورده شده است:
    London#
    interface Loopback0
    ip address 192.168.0.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 10.0.0.2 255.255.255.252
    !
    router ospf 1
    network 0.0.0.0 255.255.255.255 area 0

    Newcastle#
    interface Loopback0
    ip address 192.168.1.1 255.255.255.0
    !
    interface FastEthernet0/1
    ip address 10.0.0.6 255.255.255.252
    !
    router ospf 1
    network 0.0.0.0 255.255.255.255 area 0

    Manchester#
    interface Loopback0
    ip address 192.168.2.1 255.255.255.0
    !
    interface FastEthernet0/0
    ip address 10.0.0.10 255.255.255.252
    !
    router ospf 1
    network 0.0.0.0 255.255.255.255 area 0

    حال اجازه دهید نگاهی به پیکربندی روتر PE1 داشته باشیم. در روتر PE1، ابتدا به پیکربندی VRF*ها و سپس تنظیمات مربوط به RD یا Route Distinguisher آنها پرداخته و در ادامه نیز Route Target*ها بین VRF*ها را پیکربندی می*کنیم:
    ip vrf london
    rd 65001:1
    route-target export 65001:1
    route-target import 65001:3
    route-target import 65001:2
    !
    ip vrf manchester
    rd 65001:3
    route-target export 65001:3
    route-target import 65001:1
    !
    ip vrf newcastle
    rd 65001:2
    route-target export 65001:2
    route-target import 65001:1

    در گام بعدی می*بایست هر یک از اینترفیس*ها را به VRF مربوطه assign نماییم:
    interface Loopback100
    ip address 7.7.7.7 255.255.255.255
    !
    interface FastEthernet0/0
    ip vrf forwarding london
    ip address 10.0.0.1 255.255.255.252
    !
    interface FastEthernet0/1
    ip vrf forwarding newcastle
    ip address 10.0.0.5 255.255.255.252
    !
    interface FastEthernet1/0
    no switchport
    ip vrf forwarding manchester
    ip address 10.0.0.9 255.255.255.252

    دلیل ایجاد Loopback*ها در هر یک از روترهای Barnch*ها این است که می*خواهیم پروتکل BGP را فعال نموده و از آنها در نقش router-id برای BGP استفاده نماییم. از آنجاییکه سایت*ها می*خواهند از طریق پروتکل OSPF با یکدیگر صحبت کنند، می*بایست در گام بعدی پروتکل OSPF را بر روی اینترفیس*های روتر PE1 فعال نماییم.
    router bgp 1
    no synchronization
    no auto-summary
    !
    address-family ipv4 vrf newcastle
    redistribute connected
    redistribute ospf 2 vrf newcastle match internal
    no synchronization
    exit-address-family
    !
    address-family ipv4 vrf manchester
    redistribute connected
    redistribute ospf 3 vrf manchester match internal
    no synchronization
    exit-address-family
    !
    address-family ipv4 vrf london
    redistribute connected
    redistribute ospf 1 vrf london match internal
    no synchronization
    exit-address-family

    نکته*ای که می*بایست در دستور redistributed ospf 1 vrf London match internal از پیکربندی فوق به آن توجه نمود، این است که من فقط دستور redistributed ospf 1 vrf London را تایپ کرده ولی در ادامه دستور match internal نیز بصورت پیش*فرض به آن اضافه شده است. شما ممکن است نیاز داشته باشید تا در بعضی از سایت*های خود از سایر پارامترها در روت*های External OSPF خود استفاده نمایید (شما ممکن است پروتکل EIGRP را در جایی در شبکه داخلی خود Redistribute نمایید).
    سرانجام در آخرین مرحله تنها می*بایست پروتکل BGP را در هر یک از instance*های OSPF خود، Redistribute نماییم:
    router ospf 1 vrf london
    redistribute bgp 1 subnets
    !
    router ospf 2 vrf newcastle
    redistribute bgp 1 subnets
    !
    router ospf 3 vrf manchester
    redistribute bgp 1 subnets

    بنابراین می*توان گفت این تقریباً همان چیزی است که ما به آن نیاز داشتیم. حال اجازه دهید تا LAN IPی هر یک از سایت*ها را به sourceی برابر Loopback 0، Ping کردن تا مطمئن شویم که روت*ها به درستی توسط روترها یاد گرفته شده*اند.
    LondonCE#ping 192.168.2.1 so lo0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.0.1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/34/44 ms
    LondonCE#ping 192.168.1.1 so lo0
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.0.1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/36/52 ms
    آخرین چیزی که می*بایست چک کنیم، این است که هیچ ارتباطی نباید بین سایت*های Newcastle و Manchester وجود داشته باشد:
    NewcastleCE#sh ip route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    O E2 10.0.0.0 [110/1] via 10.0.0.5, 02:44:31, FastEthernet0/1
    C 10.0.0.4 is directly connected, FastEthernet0/1
    192.168.0.0/32 is subnetted, 1 subnets
    O E2 192.168.0.1 [110/2] via 10.0.0.5, 02:44:31, FastEthernet0/1
    C 192.168.1.0/24 is directly connected, Loopback0

    NewcastleCE#ping 192.168.0.1 so lo0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.1.1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/39/52 ms

    NewcastleCE#ping 192.168.2.1 so lo0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.2.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.1.1
    …..
    Success rate is 0 percent (0/5)

    همانطور که مشاهده می*شود، ما روت*ها از London دریافت نموده*ایم، اما نه از Manchester و این دقیقاً همان چیزی است که ما در نظر داشتیم. حال تنها جهت روشن شدن ابهامات، در ادامه روتر Manchester را چک خواهیم کرد:
    ManchesterCE#sh ip route

    Gateway of last resort is not set

    10.0.0.0/30 is subnetted, 2 subnets
    C 10.0.0.8 is directly connected, FastEthernet0/0
    O E2 10.0.0.0 [110/1] via 10.0.0.9, 02:48:10, FastEthernet0/0
    192.168.0.0/32 is subnetted, 1 subnets
    O E2 192.168.0.1 [110/2] via 10.0.0.9, 02:48:10, FastEthernet0/0
    C 192.168.2.0/24 is directly connected, Loopback0

    ManchesterCE#ping 192.168.0.1 so lo0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.0.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.2.1
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 28/40/56 ms

    ManchesterCE#ping 192.168.1.1 so lo0

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
    Packet sent with a source address of 192.168.2.1
    …..
    Success rate is 0 percent (0/5)



    منبع: کتاب مرجع آموزش CCIE Routing and Switching- مهندس میثم ناظمی- انتشارات ناقوس

  9. The Following 3 Users Say Thank You to perspolis For This Useful Post:


  10. #6
    Junior Member
    تاریخ عضویت
    Jan 2013
    نوشته ها
    29
    Thanked: 3
    با تشکر از دوستان فقط یک سوال بستر ارتباطی ما در VRF Lite می تونه هر چی باشه؟ به طور مثال frame relay- hdlc-ppp-ATM و یا از این موارد؟

  11. #7
    Junior Member
    تاریخ عضویت
    Jul 2012
    نوشته ها
    8
    Thanked: 0
    ممنون
    کسی از دوستان میتونه route target رو خیلی ساده و قابل درک توضیح بده؟

  12. #8
    Senior Member amir_khalili آواتار ها
    تاریخ عضویت
    Jun 2011
    محل سکونت
    Tehran
    نوشته ها
    196
    Thanked: 355
    قسمت Control Plan در MPLS VPN:
    روترهای CE توسط IGP یا EBGP اقدام به Advertise روتهای خود به روتر PE میکنند.روترهای PE با روترهای P توسط IGP /LDP درارتباطند ولی روترهای PE با همدیگه توسط iBGP در ارتباطند.
    زمانیکه چندین مشتری اقدام به اعلام روتهاشون به روتر PE میکنن، به VRF هر مشتری در BGP Table روتر PE مقدار RT اضافه میشه و به سایر PE ها بر اساس iBGP اعلام میشه. این عملیات در مبداء بصورت export rt کانفیگ میشه و در مقصد توسط کانفیگ import rt روتر PE میفهمه مربوط به کدوم VRF مشتریه و تحویل اون میده.
    MCITP-MCSA-MCTS-CCNA R&S-CCNP R&S-CCIE R&S

  13. The Following User Says Thank You to amir_khalili For This Useful Post:


  14. #9
    Junior Member
    تاریخ عضویت
    Jul 2012
    نوشته ها
    8
    Thanked: 0
    ممنون دوست عزیز توضیح کاملی بود
    یه سوال دیگه هم داشتم اونم اینکه address family ipv4 یعنی چی؟ و چه کاری انجام میده؟

  15. #10
    Senior Member amir_khalili آواتار ها
    تاریخ عضویت
    Jun 2011
    محل سکونت
    Tehran
    نوشته ها
    196
    Thanked: 355
    برای نوشتن روت به ازای vrf هر مشتری از Address Family استفاده میکنیم.
    روی روتر PE در ارتباط MPLS VPN:
    کد HTML:
    router bgp 65000
    address-family ipv4 vrf CUST-A
    MCITP-MCSA-MCTS-CCNA R&S-CCNP R&S-CCIE R&S

  16. The Following User Says Thank You to amir_khalili For This Useful Post:


صفحه 1 از 2 12 آخرینآخرین

موضوعات مشابه

  1. تفاوت lan base و lan lite
    توسط a3mooniii در انجمن Routing & Switching به پارسی
    پاسخ ها: 4
    آخرين نوشته: 02-03-2014, 11:42 AM

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •