نمایش نتایج: از شماره 1 تا 10 , از مجموع 10

موضوع: مسابقه bgp

  1. #1

    مسابقه bgp

    سلام دوستان،
    مدتی بود انجمن مسابقات آپدیت نشده بود
    گفتیم با یک مسابقه ساده انجمن را آپدیت کنیم

    شما مدیر BGP یک شرکت سرویس دهنده اینترنت هستید و یکی از مشتریان شما به تازگی یک Autonomous System از شرکت ARIN خریداری کرده به همراه یک کلاس آی پی ورژن 4
    به دلایلی مشتری شما تمایل به خرید تجهیزات برای راه اندازی BGP ندارد و با پرداخت هزینه ماهیانه بیشتر به شما این درخواست را دارد که شما این ASN و Prefix خریداری شده را بر روی روتر Core شبکه فعلی شما UP بشه .
    با توجه به اینکه هر روتر فقط می تواند یک ASN را پشتیبانی کند و روتر شما در حال حاضر ASN شمارا تبلیغ می کند شما چه راه حلی برای اینکه ASN مشتری مورد نظر را تبلیغ کنید پیشنهاد میکنید ؟
    شما فقط مجاز به استفاده از یک روتر لایه 3 سیسکو هستید . انواع و اقسام تکنولوژی ها آزاد هست .
    شما فقط به یک IX متصل هستید، مثلا شماره AS=333
    شما چندین Peer v4 دیگر هم دارید که هر کدام چندین Prefix تبلیغ می کنند، و نباید تنظیمات شما اختلالی در روتینگ بقیه Peer ها ایجاد کند .


    مشخصات فنی :

    شماره AS مشتری شما : 222
    شماره AS شما : 111
    شماره AS سرویس دهنده شما : 333

    Prefix مشتری شما : 2.2.2.0/24

    تمامی تنظیمات مورد نیاز را برای من پیغام خصوصی کنید
    این مسابقه تا یکشنبه 21 سپتامبر وقت دارد
    جواب مسابقه به همراه برندگان در همین تاپیک اعلام می شود
    برای پیش رفت در علم آسانسوری وجود ندارد پله ها را باید پیاده رفت.
    يادمان باشد براي يك بار ايستادن صد ها بار افتاده ايم .
    امنیت مطلق نیست.


  2. #2

    تشریح بیشترصورت مسئله


    با توجه به اینکه چند تا از دوستان در این مورد سوال پرسیدند من صورت سوال رو بیشتر توضیح میدم
    همانطور که در عکس مشخص هست شما as111 هستید و قرار هست کلاس ایپی 2.2.2.0/24 را توسط as222 بر روی روتر خودتان تبلیغ کنید .
    این مورد را باید مد نظر بگیرید که خود as111 که شما هستید در حال حاضر چندین کلاس ایپی تبلیغ می کنید که برای نمونه کلاس ایپی 1.1.1.0/24 ذکر شده است .
    در ضمن شما چندین همسایه دیگر دارید که هر کدام چندین کلاس ای پی تبلیغ می کنند که در عکس بالا نمایش داده شده است .
    برای پیش رفت در علم آسانسوری وجود ندارد پله ها را باید پیاده رفت.
    يادمان باشد براي يك بار ايستادن صد ها بار افتاده ايم .
    امنیت مطلق نیست.


  3. #3
    سلام مجدد خدمت دوستان

    خوب وقت مسابقه هم به اتمام رسید و فکر میکنم دوستان زیاد علاقه ای نسبت به مسابقات دیگه ندارند،
    به هر حال من جواب مسابقه را توضیح میدم

    روش کلی که برای حل این مساله انتخاب میکنیم as-prepend هست
    شاید الان دارید به این فکر میکنید که as-prepend برای تاثیر گذاشتن بر روی روت ها ورودی خروجی بود و افزایش تعداد AS_PATH و فرار کردن از ترانزیت شدن روتر هست،
    ولی در واقع زمانی که ما as-prepend میکنیم دقیقا داریم به AS_PATH یک یا چند بار یک شماره AS به دلخواه اضافه میکنیم و مجبور نیستیم فقط شماره AS ی که بر روی روتر فعال هست را چند بار تکرار کنیم .
    پس نیاز به as-prepend داریم، تنها تفاوت این هست که باید برای یک کلاس ایپی خاص as-prepend اتفاق بیفتد که در route-map با استفاده از یک prefix-list کلاس ایپی مورد نظر را match میکنیم .
    البته باید به بقیه prefix ها اجازه خروج را بدیم که با استفاده از یک prefix-list دیگر تمامی prefix های موجود در روتر را match میکنیم و اجازه خروج میدیم،
    البته اگر روتر شما multi-homed باشد و BGP route table کامل را داشته باشید باید با Regular Expression و as-path فقط prefix هایی را match کنید
    که در همسایگی مسقیم با شما هستند و از سمت AS های مشتری های شما تبلیغ میشود
    تنظیمات های مورد نیاز بر روی روتر


    کد:
    router bgp 111
     network 1.1.1.0 mask 255.255.255.0
     network 2.2.2.0 mask 255.255.255.0
     neighbor 10.10.10.1 remote-as 333
     neighbor 10.10.10.1 route-map PREPEND out
    !
    ip route 1.1.1.0 255.255.255.0 Null0
    ip route 2.2.2.0 255.255.255.0 Null0
    !
    ip prefix-list Prefixesv4 seq 1 permit 0.0.0.0/0 le 32
    ip prefix-list AS222 seq 2 permit 2.2.2.0/24
    !
    route-map PREPEND permit 1
     match ip address prefix-list AS222
     set as-path prepend 222
    !
    route-map PREPEND permit 2
     match ip address prefix-list Prefixesv4


    و در آخر این مسابقه فقط یک برنده داشت،
    یوزر dotnet

    با تشکر
    برای پیش رفت در علم آسانسوری وجود ندارد پله ها را باید پیاده رفت.
    يادمان باشد براي يك بار ايستادن صد ها بار افتاده ايم .
    امنیت مطلق نیست.


  4. #4
    Moderator farhadnia آواتار ها
    تاریخ عضویت
    Jul 2010
    محل سکونت
    خرم آباد
    نوشته ها
    1,550
    Thanked: 4425
    راه حل وحید راه حل ترفندی جالبیه. ولی برای این منظور یک خصوصیت جالب در bgp تعبیه شده به اسم local-as راه حل خودم را برای این مسابقه اینجا می زارم تا بیشتر بتونیم از این مسابقه یاد بگیریم البته در راه پیشنهادی من یک ضعف داره که عملا مشتری ما با استفاده از همون روتر به صورت مستقیم با service provider بالا دستی neighbor میشه:

    [Only registered and activated users can see links. ]

    کانفیگ روتر R1:

    کد:
    !
    
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    ip cef
    !
    !
    !
    ip vrf Two
     rd 222:2
     route-target export 222:2
     route-target import 222:2
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ! 
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    !
    interface Loopback1
     ip address 1.1.1.1 255.255.255.0
    !
    interface Loopback2
     ip vrf forwarding Two
     ip address 222.222.222.1 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 192.168.12.1 255.255.255.252
     duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     encapsulation ppp
     shutdown
     clock rate 2000000
    !
    interface FastEthernet0/1
     ip address 192.168.13.1 255.255.255.252
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet1/0.1
     encapsulation dot1Q 1 native
     ip address 192.168.14.1 255.255.255.252
    !
    interface FastEthernet1/0.2
     encapsulation dot1Q 2
     ip vrf forwarding Two
     ip address 192.168.14.5 255.255.255.252
    !
    router bgp 111
     no synchronization
     bgp log-neighbor-changes
     network 1.1.1.0 mask 255.255.255.0
     neighbor 192.168.12.2 remote-as 2
     neighbor 192.168.13.2 remote-as 3
     neighbor 192.168.14.2 remote-as 333
     no auto-summary
     !
     address-family ipv4 vrf Two
      neighbor 192.168.14.6 remote-as 333
      neighbor 192.168.14.6 local-as 222 no-prepend replace-as
      neighbor 192.168.14.6 activate
      no synchronization
      network 222.222.222.0
     exit-address-family
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    access-list 1 permit 222.222.222.0 0.0.0.255
    access-list 2 permit 1.1.1.0 0.0.0.255
    no cdp log mismatch duplex
    !
    !
    !
    route-map 222 permit 5
     match ip address 1
    !
    route-map B permit 5
     match ip address 2
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    
    !
    webvpn cef
    !
    end

  5. The Following 13 Users Say Thank You to farhadnia For This Useful Post:


  6. #5
    Member linuxesabz آواتار ها
    تاریخ عضویت
    Dec 2013
    محل سکونت
    تهران
    نوشته ها
    97
    Thanked: 109
    راستش من خودم با ترفند مسابقه کاملا موافقم اما خب برای من نوعی که لینوکس کارم و سیسکو زیاد بلد نیستم سطح سوال فوق العاده بالا بود
    متخصص و مدرس لینوکس

  7. The Following 3 Users Say Thank You to linuxesabz For This Useful Post:


  8. #6
    Super Moderator Mozhgan.Gholami آواتار ها
    تاریخ عضویت
    Mar 2012
    نوشته ها
    1,569
    Thanked: 4903
    نقل قول نوشته اصلی توسط farhadnia نمایش پست ها
    راه حل وحید راه حل ترفندی جالبیه. ولی برای این منظور یک خصوصیت جالب در bgp تعبیه شده به اسم local-as راه حل خودم را برای این مسابقه اینجا می زارم تا بیشتر بتونیم از این مسابقه یاد بگیریم البته در راه پیشنهادی من یک ضعف داره که عملا مشتری ما با استفاده از همون روتر به صورت مستقیم با service provider بالا دستی neighbor میشه:

    topology.png

    کانفیگ روتر R1:

    کد:
    !
    
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname R1
    !
    boot-start-marker
    boot-end-marker
    !
    !
    no aaa new-model
    memory-size iomem 5
    ip cef
    !
    !
    !
    ip vrf Two
     rd 222:2
     route-target export 222:2
     route-target import 222:2
    !
    !
    multilink bundle-name authenticated
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    ! 
    !
    !
    !
    archive
     log config
      hidekeys
    !
    !
    !
    !
    !
    !
    interface Loopback1
     ip address 1.1.1.1 255.255.255.0
    !
    interface Loopback2
     ip vrf forwarding Two
     ip address 222.222.222.1 255.255.255.0
    !
    interface FastEthernet0/0
     ip address 192.168.12.1 255.255.255.252
     duplex auto
     speed auto
    !
    interface Serial0/0
     no ip address
     encapsulation ppp
     shutdown
     clock rate 2000000
    !
    interface FastEthernet0/1
     ip address 192.168.13.1 255.255.255.252
     duplex auto
     speed auto
    !
    interface FastEthernet1/0
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet1/0.1
     encapsulation dot1Q 1 native
     ip address 192.168.14.1 255.255.255.252
    !
    interface FastEthernet1/0.2
     encapsulation dot1Q 2
     ip vrf forwarding Two
     ip address 192.168.14.5 255.255.255.252
    !
    router bgp 111
     no synchronization
     bgp log-neighbor-changes
     network 1.1.1.0 mask 255.255.255.0
     neighbor 192.168.12.2 remote-as 2
     neighbor 192.168.13.2 remote-as 3
     neighbor 192.168.14.2 remote-as 333
     no auto-summary
     !
     address-family ipv4 vrf Two
      neighbor 192.168.14.6 remote-as 333
      neighbor 192.168.14.6 local-as 222 no-prepend replace-as
      neighbor 192.168.14.6 activate
      no synchronization
      network 222.222.222.0
     exit-address-family
    !
    !
    !
    ip http server
    no ip http secure-server
    !
    access-list 1 permit 222.222.222.0 0.0.0.255
    access-list 2 permit 1.1.1.0 0.0.0.255
    no cdp log mismatch duplex
    !
    !
    !
    route-map 222 permit 5
     match ip address 1
    !
    route-map B permit 5
     match ip address 2
    !
    !
    !
    !
    control-plane
    !
    !
    !
    !
    !
    !
    !
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    
    !
    webvpn cef
    !
    end
    جناب فرهادنیا منم روی این کار می کردم یعنی رو local -as ولی به جواب نرسیدم یعنی خطای wrong as میداد خوشحالم پس اینم می شد ( پس نصف راه رو درست رفته بودم )
    برای دسترسی به بخش اشتراک باید یک روز از ثبت نام تان سپری شده باشد و یک پست مفید اعم از آموزش مطالب مرتبط با شبکه ، لینک دانلود نرم افزار و فایل های شبکه داشته باشید تا دسترسی تان به بخش مربوطه باز شود.در صورتی که دستوری تان مشکل داشت به ادمین انجمن جناب سیروس اطلاع دهید .
    پروفایل آقای سیروس :
    [Only registered and activated users can see links. ]

  9. The Following 2 Users Say Thank You to Mozhgan.Gholami For This Useful Post:


  10. #7
    Moderator farhadnia آواتار ها
    تاریخ عضویت
    Jul 2010
    محل سکونت
    خرم آباد
    نوشته ها
    1,550
    Thanked: 4425
    یعنی رو local -as ولی به جواب نرسیدم یعنی خطای wrong as میداد خوشحالم پس اینم می شد
    احتمالا روی روتر R4 شماره as رو برای دستور neighbor شماره as اصلی می دادید.
    برای استفاده از local-as باید به صورت زیر عمل کنید:
    کد:
    r4:
    router bgp 444
     neighbor 192.168.14.1 remote-as 222
    
    r1:
    
    router bgp 111
     neighbor 192.168.14.2 remote-as 444
     neighbor 192.168.14.2 local-as 222

  11. The Following 7 Users Say Thank You to farhadnia For This Useful Post:


  12. #8
    سلام بچه ها


    جناب فرهادنیا منم روی این کار می کردم یعنی رو local -as ولی به جواب نرسیدم یعنی خطای wrong as میداد خوشحالم پس اینم می شد ( پس نصف راه رو درست رفته بودم )
    همانطور که یونس گفتند با روش local-as مشتری ما به صورت مستقیم همسایه میشه با سرویس دهنده ما البته با کمک vrf در صورتی که مشتری ما هست و قرار هست با ما همسایه بشه .
    و این جواب اصلا مربوط به سوال نمیشد، بیشتر هدف از این سوال این بود که مفاهیم برای بچه ها جا بیفته،
    و اینکه وقتی صحبت از as-prepend شد فکر شما دقیقا به دنبال فرار کردن از ترانزیت شدن نره و به مفهوم as-prepend فکر کنید، یعنی اضافه کردن شماره AS به AS_PATH .
    برای پیش رفت در علم آسانسوری وجود ندارد پله ها را باید پیاده رفت.
    يادمان باشد براي يك بار ايستادن صد ها بار افتاده ايم .
    امنیت مطلق نیست.

  13. The Following 7 Users Say Thank You to Vahid For This Useful Post:


  14. #9
    Senior Member amir_khalili آواتار ها
    تاریخ عضویت
    Jun 2011
    محل سکونت
    Tehran
    نوشته ها
    198
    Thanked: 358
    جناب وحید شما لطفا زحمت بکشین و ادامه بدین و دلسرد نشین تا بتونیم از دانش و تجارب همه دوستان بهره ببریم.مخصوصا در مورد BGP که خوب پروتکل دم دستی نیست و جدای از concept پیچیده خودش ، نکات پیچیده ای هم در محیط عملی روی اون تاثیر میگذاره.
    MCITP-MCSA-MCTS-CCNA R&S-CCNP R&S-CCIE R&S

  15. The Following 5 Users Say Thank You to amir_khalili For This Useful Post:


  16. #10
    Junior Member
    تاریخ عضویت
    Jul 2016
    نوشته ها
    1
    Thanked: 0
    بسیااااااااار عالی
    [Only registered and activated users can see links. ]

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •