نمایش نتایج: از شماره 1 تا 8 , از مجموع 8

موضوع: هفته ۲۱ - System Management

  1. #1
    Member Shafagh آواتار ها
    تاریخ عضویت
    May 2010
    نوشته ها
    566
    Thanked: 5028

    هفته ۲۱ - System Management

    گزارش تمرین ها در این قسمت قرار میگیرد. (حداقل 10 خط مد نظر است.)
    برای پرسش یا رفع اشکال از موضوع بعدی استفاده کنید.


    فراموش نشود که هدف انجام تمرین است نه نوشتن گزارش. تمرین ها را انجام دهید و در صورت بروز مشکل سوال بپرسید!

    How to make the world a better place: Education

  2. The Following 8 Users Say Thank You to Shafagh For This Useful Post:


  3. #2
    Member
    تاریخ عضویت
    Apr 2011
    نوشته ها
    52
    Thanked: 97
    از Alias ها برای کوتا کردن و راحتی کار در config ها در مد های مختلف استفاده می شود
    مانند :
    alias configure i interface
    alias configure iae ip access-list extended
    alias exec ri show ip route
    alias exec rb show ip bgp
    alias interface si service-policy input

    sys log message ها را می شود فعال کرد برای ذخیر این پیغامها و می شود در عین واحد به چند میسر مختاف ارسال کرد
    که هم شامل consol/terminal می باشد که می شود هم درون خودت روتر یا به یک sys log سرور ارسال کرد.

    IOS هم از UDP و هم از TCP برای ارسال sys log می تواند استفاده کنند که پیش فرض آن UDP می باشد که مانند پروتوکل TCP قابل اطمینان نمی باشد.

    در Timestamps می توان config های جداگانه برای debugging و Log message تعریف کرد و از هم جدا کرد آتها را.

    می شود log message ها را در Flash memeory دخیره کرد.

    Archive کردن config ها و save کردن آنها باری Rollback کردن و چک کردن تغییرات خیلی کارآمد می باشد. و با دستور زیر می شود تغییرات جاری را با تغییرات Save شد چک کرد.
    #show archive config differences flash:/saved-config system:/running-config

  4. The Following 6 Users Say Thank You to alimor For This Useful Post:


  5. #3
    Moderator Alireza.mohammadi آواتار ها
    تاریخ عضویت
    Jul 2010
    محل سکونت
    iran.tehran
    نوشته ها
    1,156
    Thanked: 4555
    کامند Alias به منظور خلاصه سازی و بکار بردن برخی دستورا عمومی که کاربرد نسبتا زیادی دارد در سیتم استفاده میگردد،استفاده از قابلیت میتواند کار بر را در انجام سریع کارها و نیز سرعت بخشیدن به انجام تنظیمات کمک کند.

    کد:
    alias mode command-alias original-command no alias mode [command-alias]
    بصورت پیشفرض یک سوییچ میتواند پیامهای مختلف سیستم و Debug ها را به بخشهای مختلفی از جمله EXEC مود ارسال نماید. البته از آنجایی که وجود اید پیامها برای Troubleshooting و مونیتورینگ سیستم از اهمیت ویژه ای بر خوردار است پیشنهاد میگردد که این پیامها به Syslog Server انتقال یابد تا با Restart شدن دستگاه از بین نروند.

    اکثر دستگاه های سیسکو از پروتکل های سیسکو برای ارائه پیامها و نیز هشدار ها استفاده می نمایند،البته در دستگاه های سیسکو فضای کافی برای ذخیره گزارش ها نیست و با یکی از دو روش زیر این اطلاعات ذخیره میگردد:

    Internal Buffer :
    این حالت که بصورت پیشفرض فعال می باشد با اختصاص فضای کوچکی از Buffer که به اندازه کیلو بایت است اطلاعات را در خود ذخیره می کند.البته با شروع مجدد به کار دستگاه این داده ها نیز از بین خواهند رفت.

    Syslog :
    در این حالت سیستم با استفاده از این پرتکل داده ها را به یک سرور با فضای کافی ارسال می نماید.

    TCP keepalive ویژگی بسیار مفیدی است برای کاوش ارتباط بین دو ارتباط TCP تا ببینید که آیا آنهاهنوز هم فعال است یا خیر!
    در صورت بیکار بودن ارتباط این اتصال بصورت خودکار قطع خواهد شد. بطور مثال از جمله این ارتباطات ها میتوان به نوع اتصلات و ارتباطات VTY و EXEC اشاره نمود.
    ویرایش توسط Alireza.mohammadi : 03-07-2013 در ساعت 03:27 PM
    تا ابد آب شرمنده عباس ماند...

    [Only registered and activated users can see links. ]


    دوستانی که سوال میپرسند در نحوه بیان مشکل دقت کنند تا من و سایر دوستان بتوانیم سریع مشکل را متوجه شویم.
    مشاوره از طریق پیام خصوصی انجام می شود.

  6. The Following 7 Users Say Thank You to Alireza.mohammadi For This Useful Post:


  7. #4
    Moderator farhadnia آواتار ها
    تاریخ عضویت
    Jul 2010
    محل سکونت
    خرم آباد
    نوشته ها
    1,550
    Thanked: 4429
    برای تسریع در ورود دستورات در IOS می توان برای دستورات اختصاراتی ( نام های مستعار) تعریف کرد ، برای تعریف اختصارات از دستور alias استفاده می شود. به صورت پیش فرض اختصاراتی در IOS وجود دارد مانند s که اختصار show می باشد و یا p که نام مستعار ping است. برای دیدن تمامی نام های مستعار از دستور show alias استفاده می شود.

    رخداد های IOS در هفت سطح به نام های :

    Debug, information, notification, warning, error , Critical, alerts ,emergencies

    طبقه بندی می شود که debug با اولویت 7 پایین ترین سطح و emergencies با اولویت صفر بالاترین سطح رخداد ها می باشد. برای ذخیره log ها در یک سرور خارجی می توان از دستور logging host استفاده کرد. در صورتی که تمایل دارید از یک سطح خاص log ها به سرور ثبت رخداد ارسال شود از دستور logging trap Level-Name استفاده کنید. همچنین می توانید با استفاده از دستور logging source-interface آدرس سورس بسته های log را به آدرس اینترفیس دلخواه در روتر تنظیم نمود. با آرگومان rate-limit می توان نرخ نمایش پیام ها را در کنسول یا monitor ( ترمینال ) تنظیم نمود.

    IOS می تواند برای ارسال بسته های Logging هم از پروتکل TCP استفاده کند و هم UDP ، به صورت پیش فرض بسته های Log با UDP ارسال می شود. در صورتی که به هر دلیل تمایل دارید که پورت و یا پروتکل مورد استفاده را عوض کنید می توانید از دستور logging host Address transport [TCP/UDP] port [PortNumber] استفاده کرد.

    برای Trace کردن بسته های ارسالی از logging به سرور syslog می توان از access-list استفاده کرد ، مثال:

    access-list 100 permit udp any any eq 514
    debug ip packet detail 100
    جهت ذخیره رخداد ها در فایل بر روی حافظه flash می توان از دستور logging file flash://Address [Size] [Severity-Level]
    برای ذخیره منظم فایل تنظیمات روتر بر روی یک سرور خارجی میتوان از دستور archive استفاده کرد برای ورود به تنظیمات مربوط به Archive باید این فرمان را در global configuration وارد کنیم ، برای مشخص کردن آدرس محل ذخیره سازی اطلاعات از دستور path استفاده می کنیم ، از دستور write-memory برای ذخیره تنظیمات استفاده می شود. با دستور time-period می توان مدت زمان اجرای دستور را تعیین نمود.

    برای مشاهده تاریخچه فرایند archive گیری می توان از دستور show archive استفاده کرد. برای بازگردانی تنظیمات archive شده می توان از دستور configure replace استفاده کرد.

    سرویس Tcp-Keepalives-in و Tcp-Keepalives-out جهت چک کردن سرویس های TCP غیر فعال است تا بتوان مشخص کرد که هنوز alive هستند یا خیر برای مثال زمانی که exec-timeout بر روی Line vty برابر صفر تنظیم شده ممکن است اتصال telnet باقی مانده در حافظه باعث اتلاف منابع روتر یا سویچ شود. برای راه اندازی این سرویس ها از دستور service استفاده می کنیم.

    برای غیر فعال کردن conditional debugging نمی توان از فرمان u all استفاده کرد و باید حتما عین دستور را با پارامتر undebug قبل از آن نوشت. Conditional debugging منابع کمتری از روتر را اشغال می کند و برای استفاده در روتر های زیر بار مفید است.

    IOS زمان های متفاوتی جهت زمان timeout بر روی terminal را پشتیبانی می کند از جمله این زمان ها می توان به absolute-timeout که مشخص کننده زمانی است که یک کاربر حداکثر می تواند در ارتباط با ترمینال باشد. Exec-timeout که مشخص کننده مدت زمانی است که در صورتی که ترمینال غیر فعال باشد به صورت خودکار بسته می شود.session-timeout مشخص کننده حداکثر مدت زمانی است که یک session می تواند بر روی روتر یا ترمینال باز باشد.

  8. The Following 5 Users Say Thank You to farhadnia For This Useful Post:


  9. #5
    مدیر بخش نشر دانش Yousef Naimi آواتار ها
    تاریخ عضویت
    Aug 2010
    محل سکونت
    Tehran
    نوشته ها
    788
    Thanked: 3844

    Lightbulb

    • برای جلوگیری از tampering با اطلاعات syslog ذخیره شده ، می توان از sequence number استفاده کرد.
      Service sequence-number



    • یک روتر می تواند configuration خود را روی یک مسیر شبکه یا روی یک حافظه ی ثانویه ی غیر فرار که به روتر plug شده بطور لحظه ای ذخیره کند ، اما نمی تواند این کار را روی حافظه ی flash memory اولیه انجام دهد .
      هنگامیکه اطلاعات را روی یک مسیر شبکه ذخیره می کند ، نمی توان حداکثر تعداد کپی ها را مشخص نمود .



    • با دستور زیر می توان تفاوت های بین دو configuration ذخیره شده و در حال اجرا را مشاهده کرد .
      Show archive config differences flash:/saved-config system:/running-config
      علامت + نشان دهنده ی تنظیماتیست که در configuration دوم وجود دارد اما در config فایل اول نیست .
      علامت – هم به معنای تنظیماتی که در فایل اول هست اما در configuration دوم وجود ندارد .

      برای اینکه بدانیم چه خطوطی را باید به تنظیمات running configuration اضافه کنیم تا آن را شبیه saved configuration بکنیم ، از دستور زیر استفاده می کنیم :
      Show archive config incremental-diffs flash:/saved-config



    • در تنظیمات ntp ، نباید رویروتر خودمان از دستور زیر استفاده کرد :
      Ntp master 1
      به عبارتی تنها در صورتی می توان روتر خودمان را در stratum یک قرار دهیم که روتر مثلا خودش یک atomic clock واقعی داشته باشد و بتواند به عبارتی زمان مرجع را تولید کند .



    • Logging facility در واقع نوع string در پیامها را کنترل می کند ؛ لذا چنانچه بخواهیم پیام های log که از دستگاههای مختلف می آیند را دسته بندی کنیم ، از آن استفاده می کنیم .
      مثلا برای روتر ها local1 و برای سوییچ ها local2 را تنظیم می کنیم و سپس می گوییم که فقط پیام های facility local1 را نشان بده .



    • انواع بنر ها :
      MOTD : اولین بنر که قبل از login prompt نمایش داده می شود .
      Login : بعد از motd و قبل از login prompt نمایش داده می شود .
      Exec : بعد از login prompt در زمانیکه exec تقاضا می شود نمایش داده می شود .
    It's OK to fail, as long as you keep trying

    CCNA - CCNA Security - CCNP R&S - CCNP Security

  10. The Following 5 Users Say Thank You to Yousef Naimi For This Useful Post:


  11. #6
    مدیر CCNP Club moghaddas آواتار ها
    تاریخ عضویت
    Sep 2010
    محل سکونت
    Internet
    نوشته ها
    422
    Thanked: 1277
    - جهت تأمین امنیت NTP، می بایست از دو مکانیزم NTP Access Control و NTP Authentication استفاده کرد (استفاده از ACL همراه با 4 نوع Access-type موجود و محدود کردن آنها با مبدأ یا مقصد مشخص)

    - برخلاف SNMPv1 و SNMPv2، علاوه بر مکانیزم امنیتی noAuthNoPriv (معادل no authentiation and no encryption، کلمه ی کلیدی noauth در CLI) که در این دو مدل امنیتی وجود دارد، مکانیزم های AuthNoPriv (معادل messages are authenticated but not encrypted، کلمه ی کلیدی auth در CLI) و AuthPriv (معادل messages are authenticated and encrypted، کلمه ی کلیدی priv در CLI) در مدل SNMPv3 قابل تنظیم هستند.

    - snmp users در running-configuration قابل مشاهده نیستند

    - جهت استفاده از ip accounting access-violation نم توان از named ACL استفاده کرد؛ باید توجه داشت که تنها packetهایی که process-switched شده اند آمار دقیقی در اختیار می گذارند.

    - توسط kron تنها دستورات exec mode قابل اجرا هستند

    - ip unreachables و ip redirects بطور پیش فرض فعال هستند.

    - توسط تعیین condition برای debug، می توان پیام های نمایش داده شده را محدود به شرایط خاص کرد، مانند محدود کردن به پیام های مربوط به packetهای یک Interface و ...

    - RITE کاربردی مشابه SPAN در سوئیچ ها است.

    - مقدار threshold در SLA نباید بیش تر از timeout باشد؛ کاربرد threshold در محاسبه ی آمار SLA است.

    - توسط تنظیم archive config می توان تنظیمات مربوط به پشتیبان گیری از تنظیمات تجهیز را انجام داد.

    - با استفاده از دستور show archive config differences می توان اختلافات بین دو فایل تنظیمات را مشاده کرد.

    - پس از دستور config بجز کلمه ی کلیدی terminal، سوئیچ های مختلف و مهمی وجود دارند که می بایست به نحوه ی کاربرد آنها توجه شود؛ از جمله replace و revert

    - توسط RMON می توان بدون صرف پردازش جهت SNMP queryهای متعدد، بطور locally مقادیر MIBهای مختلف را اندازه گیری کرد و زمانی که از میران threshold مقدار اندازه گیری شده عبور کرد یک log entry ایجاد شده و trap مربوطه تنها یک بار ارسال گردد؛ و تنها زمانی trap بعدی ایجاد شود که مقدار به falling threshold رسیده است.

    - MIB OID می بایست در ساختار entry.integer.instance تنظیم گردد.

    - جهت متوقف کردن یک probe می بایست از دستور no ip sla monitor schedule x استفاده کرد.
    ویرایش توسط moghaddas : 03-08-2013 در ساعت 12:59 AM
    Network Consultant/Solutions Architect
    mohammad [at] moghaddas [dot] com
    [Only registered and activated users can see links. ]

  12. The Following 3 Users Say Thank You to moghaddas For This Useful Post:


  13. #7
    Super Moderator Saeed Alkhamis آواتار ها
    تاریخ عضویت
    Jul 2010
    محل سکونت
    Ahvaz
    نوشته ها
    811
    Thanked: 2151
    نکته: Aliases را می توان برای Route-map و Class-map هم استفاده کرد

    در سیسکو IOS قابلیتی بنام Menu وجود دارد که محیط روتر را بصورت گزینه های قابل انتخاب نمایش میدهد

    این قالبیت بیشتر برای کسانی که در قسمت Support کار میکنند استفاده می شود که بسته به نیاز مدیر یکسری دسترسی تعین میکند

    #menu OPERATOR title
    Operator Menu
    #
    menu OPERATOR text 1 Display IP Routing Table
    menu OPERATOR command 1 show ip route
    menu OPERATOR options 1 pause
    menu OPERATOR text 2 Display Running Config
    menu OPERATOR command 2 show run
    menu OPERATOR text 3 Disconnect
    menu OPERATOR command 3 exit
    menu OPERATOR clear-screen
    !
    username OPERATOR autocommand menu OPERATOR
    username OPERATOR password CISCO
    username OPERATOR privilege 15
    !
    line vty 0 4
    login local

    در این کانفیگ زمانی که کاربر OPERATOR به روتر Login کند به این Menu دسترسی دارد

    Operator Menu
    Display IP Routing Table
    Display Running Config
    Disconnect

    گزینه اول Routing Table روتر را نشان میدهد
    گزینه دوم کانفیگ موجود را نشان میدهد
    گزینه سوم Telnet را قطع میکند

    HTTP Server : این قابلیت بصورت پیش فرض فعال است authentication پیش فرض از طریق
    enable password است و قابل تغییر است که از Local database و یا از AAA استفاده کند
    نکته : اگر authentication از طریق user local باشد یوزر باید privilege level 15 داشته باشد

    Archive & Rollback
    میتوانیم تعیین کنیم که یک نسخه از کانفیگ را در جایی غیر nvram هم ذخیره کند در زمان ذخیره
    کردن کانفیگ برای هر نسخه یک عدد اضافه میکند تا هر زمانی که نیاز داشتیم بتوانیم
    کانفیگ را به نسخه دلخواه برگردانیم

    archive
    path tftp://155.1.58.100/sw1-config
    write-memory
    show archive
    The next archive file will be named tftp://155.1.58.100/sw1-config -1
    Archive # Name
    0
    1
    2
    3
    4
    5

    کانفیگ یکی از اینترفیس ها را را تغییر میدهیم

    SW1#conf t
    Enter configuration commands, one per line. End with CNTL/Z.
    SW1(config)#int vlan 67
    SW1(config-if)#shutdown
    SW1(config-if)#ip address 155.1.76.7 255.255.255.0

    با این دستور فرق بین کانفیگ ذخیره شده و کانفیگ موجود را نشان میدهد

    SW1#show archive config differences flash:/saved-config
    system:/running-config
    Contextual Config Diffs
    interface Vlan67
    + ip address 155.1.76.7 255.255.255.0
    +shutdown
    interface Vlan67
    ip address 155.1.67.7 255.255.255.0

    اگر بخواهیم که کانفیگ را به حالت قبلی برگردانیم از این دستور استفاده میکنیم

    SW1#configure replace flash:/saved-config list force
    !Pass 1
    !List of Commands:
    interface Vlan67
    no ip address 155.1.76.7 255.255.255.0
    no shutdown
    interface Vlan67
    ip address 155.1.67.7 255.255.255.0
    end
    Total number of passes: 1
    Rollback Done

  14. The Following 5 Users Say Thank You to Saeed Alkhamis For This Useful Post:


  15. #8
    Senior Member saeedbabaei24 آواتار ها
    تاریخ عضویت
    Dec 2011
    نوشته ها
    134
    Thanked: 276
    گزارش گیری با Access-list

    اگر در انتهای Access-list عبارت log-input را نیز اضافه کنیم، بسته های مربوط به پروتکلی که Access-list شامل آن میشود گزارش میشوند.

    ip access-list extended LOGGING
    permit udp any any eq OSPF log-input
    permit ip any any

    عبارت log-input در انتهای دستور MAC آدرس Device ای که بسته از آنجا فرستاده شده را نیز شامل میشود.


    برای تعیین threshold :

    ip access-list log-update threshold 2

    و interval :

    ip access-list logging interval 10

    برای غیر فعال کردن گزارش های mismatch duplex :

    no cdp log mismatch duplex


    برای اضافه کردن اینترفیس در Update های CDP :

    cdp source-interface Loopback0

    هر چند ثانیه پیام های CDP ارسال شوند:

    cdp timer TIME

    همسایه ها پیام های CDP را هر چند وقت ارسال کنند:

    cdp holdtime TIME

    غیر فعال کردن CDP برای یک اینترفیس خاص :

    R(config-if)#no cdp enable
    غیر فعال کردن CDP :

    R(config)#no cdp run


    Debugging مشروط:

    برای مشروط کردن اشکال زدایی (Debugging) از دستور

    Rack1R6#debug condition interface fastEthernet
    استفاده میکنیم. این دستور برای روتر های مشغول و وقتی که دنبال مورد خاصی در Debug کردن هستیم مناسب است.

    میتوان از روتر به عنوان tftp server استفاده کرد و فایل هایی را که سایرین قرار است از آنها استفاده کنند با Alias مناسب نام گذاری کرد. همچنین دسترسی سایرین را با Access-list کنترل کرد:

    Router(config)#tftp-server flash:… alias config Access-listNO

    برای برنامه ریزی کار هایی مثل Save کردن کانفیگ در زمان های مشخص از Kron استفاده میکنیم:

    Router(config)#kron occurrence save at 10:00 sun recurring
    Router(config-kron-occurrence)#policy-list CONFIG

    R(config)#kron policy-list CONFIG
    Router(config-kron-policy)#cli copy run start



    روتر ها میتوانند از چند NTP Server استفاده کنند، برایی ترجیح دادن یک سرور به دیگری:

    Router(config)#ntp server IP-Address prefer

    برای حالتی که قصد ارسال بسته های NTP را به صورت Broadcast داریم روی اینترفیس روتری که قرار است ارسال کند:

    Router(config-if)#ntp broadcast

    و روی اینترفیس روتری که قرار است دریافت کند:

    Router(config-if)#ntp broadcast client

    بسته های NTP به صورت Multicast نیز ارسال و دریافت میشوند. در این صورت ابتدا باید Multicasting روی روتر ها فعال شده باشد:

    Router(config)#ip multicast-routing
    Router(config-if)#ip pim dense-mode


    Router(config-if)#ntp multicast MULTICAST_GROUP

    به کمک Remote Shell میتوانیم ار طریق روتر های دیگر به دستورات روتر خاصی دسترسی داشته باشیم:
    برای اینکار ابتدا باید RSH را رو روتر مقصد فعال کنیم:

    Router(config)#ip rcmp rsh
    Router(config)#ip Rcmp remote-host Name_of_LocalUserName IP_of_RemoteUser Name_of_RemoteHost enable

    برای دسترسی به روتر ار راه دور :

    Router#rsh IP_of_Destination /user Remote_UserName COMMAND

  16. The Following 5 Users Say Thank You to saeedbabaei24 For This Useful Post:


موضوعات مشابه

  1. هفته ۲۱ - System Management - طرح سوال / مشکلات
    توسط Shafagh در انجمن CCIE Room
    پاسخ ها: 5
    آخرين نوشته: 03-06-2013, 11:11 PM
  2. VLAN Management
    توسط perspolis در انجمن CCNP Club
    پاسخ ها: 1
    آخرين نوشته: 10-03-2012, 01:58 PM
  3. Management tools for NME-IPS
    توسط masud در انجمن Security و امنیت شبکه به پارسی
    پاسخ ها: 1
    آخرين نوشته: 01-18-2012, 12:50 AM
  4. پیکربندی WEB Management Console سوئیچ های سیسکو
    توسط hozour64 در انجمن General Networking - شبکه به پارسی
    پاسخ ها: 0
    آخرين نوشته: 03-30-2011, 11:43 PM

مجوز های ارسال و ویرایش

  • شما نمیتوانید موضوع جدیدی ارسال کنید
  • شما امکان ارسال پاسخ را ندارید
  • شما نمیتوانید فایل پیوست کنید.
  • شما نمیتوانید پست های خود را ویرایش کنید
  •